MP40's Modelguns Forum

International Forum for Modelgun enthusiasts
 
HomeFAQRegisterLog in

Share | 
 

 Beretta M93R Firing Problems... Am I Loading Carts Correctly?

View previous topic View next topic Go down 
AuthorMessage
Cerwyn
Cerwyn (Site Admin)
Cerwyn (Site Admin)
avatar

Number of posts : 10633
Age : 58
Location / Country : North Wales
Registration date : 2008-07-20

PostSubject: Beretta M93R Firing Problems... Am I Loading Carts Correctly?   Fri Aug 15, 2008 11:51 am

Post by Duncanature

I'm new to Model Guns. I just bought a Beretta M93R... and I can't seem to figure out how to load the damn caps... because the instructions are in Japanese. What usually happens is I load the cap in and when I pull back and release the slide, the cap ignites before I even pull the trigger. I really don't know what the hell I'm doing. Can someone help me out?
Back to top Go down
View user profile http://mp40modelguns.forumotion.net
Cerwyn
Cerwyn (Site Admin)
Cerwyn (Site Admin)
avatar

Number of posts : 10633
Age : 58
Location / Country : North Wales
Registration date : 2008-07-20

PostSubject: Re: Beretta M93R Firing Problems... Am I Loading Carts Correctly?   Fri Aug 15, 2008 11:51 am

Post by LDR

Hi,
Have you checked this thread:

http://www.mp40modelguns.com/forum2/viewtopic.php?t=1148

Has aload of info about loading caps etc.
Back to top Go down
View user profile http://mp40modelguns.forumotion.net
Cerwyn
Cerwyn (Site Admin)
Cerwyn (Site Admin)
avatar

Number of posts : 10633
Age : 58
Location / Country : North Wales
Registration date : 2008-07-20

PostSubject: Re: Beretta M93R Firing Problems... Am I Loading Carts Correctly?   Fri Aug 15, 2008 11:52 am

Post by Duncanature

Okay... I know I have it loaded right now, but it still won't fire.

What's the deal?
Back to top Go down
View user profile http://mp40modelguns.forumotion.net
Cerwyn
Cerwyn (Site Admin)
Cerwyn (Site Admin)
avatar

Number of posts : 10633
Age : 58
Location / Country : North Wales
Registration date : 2008-07-20

PostSubject: Re: Beretta M93R Firing Problems... Am I Loading Carts Correctly?   Fri Aug 15, 2008 11:53 am

Post by Claymore

Is this a brand new gun or 2nd hand and the first thing to check is that the detonator pin in the barrel is positioned right it sounds as if its too far forward and so detonating the cap. take the slide off remove the grub screw that is in the barrel and holds the pin in place then push the pin (you will need something to help you do this like a metal bar) fully home if you cannot push it further in then it is seated right (give it a good push) then replace the grub screw.
If that does not work let us know and also which model of 93 this is there a 3 versions, an abs a HW and the new proto, if this is a second hand one there are possible reasons you get this problem.
Back to top Go down
View user profile http://mp40modelguns.forumotion.net
Cerwyn
Cerwyn (Site Admin)
Cerwyn (Site Admin)
avatar

Number of posts : 10633
Age : 58
Location / Country : North Wales
Registration date : 2008-07-20

PostSubject: Re: Beretta M93R Firing Problems... Am I Loading Carts Correctly?   Fri Aug 15, 2008 11:53 am

Post by Duncanature

I believe I have the HW version. I have absolutely no idea what I'm doing. I don't know what a grub screw is...
Back to top Go down
View user profile http://mp40modelguns.forumotion.net
Cerwyn
Cerwyn (Site Admin)
Cerwyn (Site Admin)
avatar

Number of posts : 10633
Age : 58
Location / Country : North Wales
Registration date : 2008-07-20

PostSubject: Re: Beretta M93R Firing Problems... Am I Loading Carts Correctly?   Fri Aug 15, 2008 11:54 am

Post by Mark



Ok, take out your barrel and look on its bottom for a small set screw ( the allen wrench for this small screw is in the bag of extra pieces) Now, carefully loosen this screw and then, look in the chamber and push against the pointed steel "detonator" inside. If it moves backwards at all then that was your problem. If it won't move at all its one of two things, the screw is still touching the detonator and it needs to be unscrewed even more or, the cartridges are loaded wrong.

When you tighten the screw, PLEASE DO IT CAREFULLY! OR IT WILL STRIP OUT OR BREAK THE BARREL.

Ok, now, the cartridges:



The little brass "primer" fits into the cartridge first, followed by the face-up cap. Then, the "piston" with the small end pointing down. And then finally, the "bullet" is placed on and screwed tightly down. The clear "straw" is the cap loader:



This is used to (safely) push the cap into the cartridge body. The cap has to be seated against the brass "primer" at the cartridges bottom with the face of the cap facing towards the screw on "bullet" (if the little brass "primer" is not held down by the cap, it will move and cause all sorts of firing problems)

A little grease (carefully) applied to the inside of the cartridge before this "piston" is placed in and pressed into the cartridge case mouth will help it to slide when the cap detonates. The "piston" can be either pressed up against the cap or flush with the cartridge mouth.



Screw on the Bullet and load the cartridges into the gun..
_________________
Wanted to buy: MGC Sten MK3....trades?(still)

MGC MP40 Marushin MP40 Nakata MP40 TRC MP40

Modelgun manufacturers, past and present:CMC,CAW,Hudson,HWS,LS,MGC(R.I.P. 1960's~2007) Marushin,Marui,Kokusai,Shoei,Tanaka and Western Arms

Last edited by mark on Thu Jun 29, 2006 2:28 am; edited 1 time in total
Back to top Go down
View user profile http://mp40modelguns.forumotion.net
Cerwyn
Cerwyn (Site Admin)
Cerwyn (Site Admin)
avatar

Number of posts : 10633
Age : 58
Location / Country : North Wales
Registration date : 2008-07-20

PostSubject: Re: Beretta M93R Firing Problems... Am I Loading Carts Correctly?   Fri Aug 15, 2008 11:56 am

Post by Duncanature

Okay... I've got the caps down... but as far as unscrewing the barrel... perhaps you could provide a visiual aid for this as well?


Edit: Remainder of this topic moved to "Modelgun Problems"
Ref: http://mp40modelguns.forumotion.net/modelgun-problems-f5/beretta-m93r-firing-pin-problems-t394.htm#2506
Back to top Go down
View user profile http://mp40modelguns.forumotion.net
Sponsored content




PostSubject: Re: Beretta M93R Firing Problems... Am I Loading Carts Correctly?   

Back to top Go down
 
Beretta M93R Firing Problems... Am I Loading Carts Correctly?
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Bocar 34 PICT-3 Carb Problems
» FAQ: Steering Column Slop, Problems & Replacement
» Push Carts
» Instruments panel problems.
» 1995 Riviera S/C intermittant misfire...killing me!

Permissions in this forum:You cannot reply to topics in this forum
MP40's Modelguns Forum :: Modelgun Caps, Cartridges and Magazines-
Jump to: